[Users] [Bug 2916] New: Lost email when IMAP server restarted during automatic copy of outgoing message

noreply at thewildbeast.co.uk noreply at thewildbeast.co.uk
Wed May 8 12:31:27 CEST 2013


http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2916

            Bug ID: 2916
           Summary: Lost email when IMAP server restarted during automatic
                    copy of outgoing message
    Classification: Unclassified
           Product: Claws Mail
           Version: 3.9.0
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Other
          Assignee: users at lists.claws-mail.org
          Reporter: jnieder at betriebsdirektor.de

First my apologies for the quality of the bug report. I should have noted down
the exact error message but I didn't expect to lose an email. :-\

I replied to an email that resided on an IMAP server. When I was done, I send
the email. The folder in which the original email was had the "Save copy of
outgoing messages to this folder instead of Sent" option set. Since I had that
folder (and therefore the connection to the IMAP sever) open, I didn't expect
any problems with this. But claws-mail opened an error message which sadly, I
cannot recall precisely. Sorry. I registered the error message as something
going wrong with the login/authentication, so I thought I had just mistyped the
password for the SMTP server but after closing the error message the email
composing window was also closed. I checked the local sent folder, but my email
was completely gone. I later figured from the log that when claws-mail tried to
move the email to the IMAP folder, the IMAP server (dovecot) decided it needed
to restart itself because of a clock change.

I understand that this might be difficult to reproduce but perhaps you can
check the code to see where an email might get lost under such circumstances.
While I do hope that this does not happen again, but if it does, I'll try to
note down the exact error message and copy claws-mail's logs to help debugging
it.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the Users mailing list