[Users] Claws-mail on CentOS

wwp subscript at free.fr
Thu Mar 22 16:35:24 CET 2018

Hello Andreas,

On Thu, 22 Mar 2018 15:13:26 +0100 (CET) Andreas Meyer <anmeyer at mailbox.org> wrote:

> > Richard <lists-claws at listmail.innovate.net> hat am 22. März 2018 um 14:26 geschrieben:  
> > > Are python and perl essential for claws-mail to work? There are
> > > other problems compiling with python and perl.
> > >   
> > 
> > Could you be more specific about your python and perl issues? Your
> > centos system will have python (it's integral to some system
> > management aspects, and updating it has to be done with great care).
> > I believe that base perl is also installed by default. 
> > 
> > You may need development libraries that don't get installed by
> > default.  
> checking whether to build newmail plugin... yes
> checking whether to build notification plugin... yes
> checking whether to build pdf_viewer plugin... no
> configure: WARNING: "Plugin pdf_viewer will not be built; missing libpoppler-glib "
> checking whether to build perl plugin... no
> configure: WARNING: "Plugin perl will not be built; missing libperl "
> checking whether to build python plugin... no
> configure: WARNING: "Plugin python will not be built; missing python "
> checking whether to build pgpcore plugin... yes
> Disabled due to missing dependencies:
>             - fancy
>             - pdf_viewer
>             - perl
>             - python
>             - vcalendar
> But python-devel-2.7.5-58.el7.x86_64 and perl-devel-5.16.3-292.el7.x86_64 are already installed.
> Also is libical-devel-1.0.1-1.el7.x86_64

For perl (based on what's installed here, I presume it's):
would you mind trying that? If more is needed, we'd need to dig into
the detail.

For python (based on ..):
but since you have it.. I don't remember what more is needed :-/, I
must admit that perl and python deps are often a nightmare since they
imply lots of packages, not always the same across distros, nothing

For fancy:
you might want to check how the RPM for centos is build and what are its dependencies, for instance:
there, you can see that it 'requires' libwebkitgtk-1.0.so.0()(64bit), which is:
(install the -devel one).

For pdf_viewer:
and probably compat-poppler022-glib, if what I see at:
leads me to :

You might want to install libical 2.0.0 from the sources, for
vcalendar, see https://github.com/libical/libical/releases. I didn't
try the 3.x.

You might also want to install a recent ytnef from the sources
in /usr/local/ (see https://github.com/Yeraze/ytnef/releases).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: OpenPGP digital signature
URL: <http://lists.claws-mail.org/pipermail/users/attachments/20180322/faad0e64/attachment.sig>

More information about the Users mailing list