[Users] [Bug 4139] New: Clawsker broken with perl 5.22+

noreply at thewildbeast.co.uk noreply at thewildbeast.co.uk
Fri Dec 21 18:18:27 CET 2018


            Bug ID: 4139
           Summary: Clawsker broken with perl 5.22+
    Classification: Unclassified
           Product: clawsker
           Version: GIT
          Hardware: PC
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: default
          Assignee: users at lists.claws-mail.org
          Reporter: glitsj16 at gmail.com

One of the recent commits in claws-mail adds a new hidden pref "use_tls_sni"
When trying to set that I noticed clawsker is quite broken Arch Linux. Besides
an issue caused by incorrect dependencies in the Arch Linux packaging of
clawsker (easily fixed by rebuilding with the correct ones), the program
refuses to start and throws a message about an uninitialized value (details
below). Here's what I've done:

OS: Arch Linux (fully updated)

$ clawsker
Can't locate Gtk3.pm in @INC (you may need to install the Gtk3 module) (@INC
contains: /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl
/usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl
/usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at /usr/bin/clawsker
line 22.
BEGIN failed--compilation aborted at /usr/bin/clawsker line 22.

That's the packaging bug showing. Clawsker needs different dependencies than
those currently stated in the official package
I'll be filing an issue for that asap. Installing perl-gtk3 and try again:

$ sudo pacman -S perl-gtk3

$ clawsker
Can't locate File/Which.pm in @INC (you may need to install the File::Which
module) (@INC contains: /usr/lib/perl5/5.28/site_perl
/usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl
/usr/share/perl5/core_perl) at /usr/bin/clawsker line 23.
BEGIN failed--compilation aborted at /usr/bin/clawsker line 23.

Another faulty dependency...

$ sudo pacman -S perl-file-which

$ clawsker
Use of uninitialized value $fver[2] in string eq at /usr/bin/clawsker line 298.
Invalid version string at /usr/bin/clawsker line 298.

I'm not at all experienced in Perl, but I'm getting the same error on Ubuntu,
albeit on different lines of the script:

OS: Ubuntu 16.04 (fully updated)

$ apt-cache policy clawsker
  Installed: 0.7.13-1
  Candidate: 0.7.13-1
  Version table:
 *** 0.7.13-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy perl
  Installed: 5.22.1-9ubuntu0.6
  Candidate: 5.22.1-9ubuntu0.6
  Version table:
 *** 5.22.1-9ubuntu0.6 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial-security/main amd64
        100 /var/lib/dpkg/status
     5.22.1-9 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

$ clawsker
Use of uninitialized value $fver[2] in string eq at /usr/bin/clawsker line 260.
Invalid version string at /usr/bin/clawsker line 260.

Please note that I have very little experience with Perl, and it might be yet
too soon to expect to see the newly added hidden pref "use_tls_sni", but
clawsker seems broken with these perl versions. Don't have access to different
perl versions currently, so the actual version number mentioned in this bug
summary might not be fully correct. Please advise.


You are receiving this mail because:
You are the assignee for the bug.

More information about the Users mailing list