[Users] [Bug 2678] New: Claws hangs when fetching from local IMAP server

noreply at thewildbeast.co.uk noreply at thewildbeast.co.uk
Wed Jun 13 07:52:40 CEST 2012


http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2678

           Summary: Claws hangs when fetching from local IMAP server
           Product: Claws Mail
           Version: 3.8.0
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Folders/IMAP
        AssignedTo: users at lists.claws-mail.org
        ReportedBy: sg.backuponly at gmail.com


I am using Claws-Mail 3.8.0 on a Debian Squeeze system - it's a wonderful
program.  Claws is configured to load mails from a local Dovecot IMAP server on
the same machine (which in turn is updated using offlineimap). I've been using
this combination for four years now with hardly any hitches.  However,
recently, things have begun to slow down a lot, and ten days ago Claws began to
hang entirely on certain operations.  So far I have found this to be the case
when:

* Trying to open certain messages - there seems to be no clear pattern
* Running "rebuild folder tree" on the IMAP account

Once it hangs Claws will not respond to anything including a TERM signal.  It
has to be killed with kill -9.  

In case it may help with diagnosing the problem, I've attached the strace
output that results when I start claws, set it to online mode (it always starts
offline for some reason), and then try to rebuild the folder tree.

I have deleted my entire ~/.claws-mail folder and started from scratch, to no
avail.

-- 
Configure bugmail: http://www.thewildbeast.co.uk/claws-mail/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Users mailing list